Logical Functions

Use the IF Function

\[ = \text{IF}(\text{Statement}, \text{IFtrue}, \text{IFfalse}) \]

- **Statement** - comparison statement to which you try to match.
- **IFtrue** - result if the comparison matches the statement.
- **IFfalse** - result if the comparison does not match the statement.

Combine Logical Functions

\[ = \text{IF}(\text{AND}(\text{Statement1}, \text{Statement2}), \text{IFtrue}, \text{IFfalse}) \]

Ensures that both statements must be true.

\[ = \text{IF}(\text{OR}(\text{Statement1}, \text{Statement2}), \text{IFtrue}, \text{IFfalse}) \]

Tests both statements, either of which can be true.

\[ = \text{IF}(\text{NOT}(\text{Statement}), \text{IFtrue}, \text{IFfalse}) \]

Returns the reverse value for the condition.

Concatenate & Parse Cells (Merge & Split)

Concatenate (Merge) Data in Separate Cells

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>John</td>
<td>Smith</td>
<td>Smith, John</td>
</tr>
<tr>
<td>2</td>
<td>Jane</td>
<td>Jones</td>
<td>Jones, Jane</td>
</tr>
</tbody>
</table>

\[ = \text{CONCATENATE}(B1, "", C1) \]

Parse (Split) Data into Separate Cells

1. Select the cells to parse (split)
2. Go to **Data &gt; Text to Columns...** to open the wizard.
3. **Step 1 of 3**: Be sure Delimited is selected, then click **Next >**
4. **Step 2 of 3**: Select the delimiter type, then click **Next >**
5. **Step 3 of 3**: Choose the data type for the column if necessary, then click **Finish**

Use the DATEDIF Function

Syntax: \[ = \text{DATEDIF}(\text{Date1}, \text{Date2}, \text{Interval}) \]

- **Date1** — first date, in standard Excel serial-date format.
- **Date2** — second date, in standard Excel serial-date format.
- **Interval** — unit of time for the result.

Date1 must be ≤ Date2 or a #NUM! error will be returned. If either Date1 or Date2 is not a date, a #VALUE! error will be returned.

Interval must be one of the following codes:

<table>
<thead>
<tr>
<th>Code</th>
<th>Meaning</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;m&quot;</td>
<td>Months</td>
<td>Number of complete months between Date1 and Date2.</td>
</tr>
<tr>
<td>&quot;d&quot;</td>
<td>Days</td>
<td>Number of days between Date1 and Date2.</td>
</tr>
<tr>
<td>&quot;y&quot;</td>
<td>Years</td>
<td>Number of complete years between Date1 and Date2.</td>
</tr>
<tr>
<td>&quot;ym&quot;</td>
<td>Months Excluding Year</td>
<td>Number of months between Date1 and Date2, as if Date1 and Date2 were in the same year.</td>
</tr>
<tr>
<td>&quot;yd&quot;</td>
<td>Days Excluding Years</td>
<td>Number of days between Date1 and Date2, as if Date1 and Date2 were in the same year.</td>
</tr>
<tr>
<td>&quot;ymd&quot;</td>
<td>Days Excluding Months &amp; Years</td>
<td>Number of days between Date1 and Date2, as if Date1 and Date2 were in the same month and year.</td>
</tr>
</tbody>
</table>

When passing the interval code to the DATEDIF function, enclose it in quotes if you are passing a literal value to the function.
Use HLOOKUP

You must have a data table for which to lookup information indexed in horizontal rows.

=HLOOKUP(lookup_value, table_array, row_index_num, range_lookup)

- **lookup_value** is the reference or address of the comparison cell.
- **table_array** is the data table range that is searched (including row labels).
- **row_index_num** indicates how many rows to move down.
- **range_lookup** is a logical argument that returns a true or false value (optional)

Use VLOOKUP

You must have a data table for which to lookup information indexed in vertical columns.

=VLOOKUP(lookup_value, table_array, col_index_num, range_lookup)

- **lookup_value** is the reference or address of the comparison cell.
- **table_array** is the data table range that is searched (including column labels).
- **col_index_num** indicates how many columns to move the right.
- **range_lookup** is a logical argument that returns a true or false value (optional)

Use Data Validation

1. Select the cell(s) for which you will define the data validation criteria.
2. Go to **Data** → **Validation...** to open the **Data Validation** dialog box. The **Settings** tab is active.
3. Click the **Allow:** arrow to display a list of options, and then select the option you desire.
4. Click the **Data:** arrow to display a list of conditional operators, and then select the option you desire. Complete the remaining fields that are pertinent to your choices.
5. Click the **Input Message** tab and click in the **Title:** field. Type the title of the dialog box to appear.
6. Click the **Input Message:** field and type the message you’d like the dialog box to display.
7. Click the **Error Alert** tab, click the **Style:** arrow to choose an icon that will display.
8. Click the **Title:** field and type the title to appear.
9. Click the **Error Message:** field and type the message you’d like the dialog box to display.
10. Click **OK**.

- Click **Circle Invalid Data** on the Auditing toolbar to locate cells that don’t meet the validation criteria.
- Click **Clear Validation Circles** on the Auditing toolbar to clear the circle.

Use Data Validation with Lookup Tables

When creating the data validation, use a formula to reference the lookup table’s column in the **Source:** field.

Visual Basic

Record a Macro

1. Go to **Tools** → **Macro** → **Record New Macro...** to record your actions for the macro.
2. Give the macro a name and description and click **Close**.
3. Perform the actions you would like recorded.
4. Click **Stop** on the Macros toolbar when finished. **OR**, go to **Tools** → **Macro** → **Stop Recording**.

- To run a macro, press the shortcut key if you provided one or go to **Tools** → **Macro** → **Macros...**, select the macro and click **Run**. You may also assign the macro to a button as described below.

Edit a Macro

- Open the Visual Basic window by going to **Tools** → **Macro** → **Macros...**. **OR**, press ALT+F8. You can edit any macro using Visual Basic for Applications (VBA) code.

Debug a Macro

- Open the Visual Basic window by going to **Tools** → **Macro** → **Macros...**
- Select the macro under **Macro Name:** and click **Step Into**.
- Go to **Debug** → **Step Into OR** press F8 to move to execute the next line of code.
Create a Macro Button

1. Open the Forms toolbar and select the Button button.
2. Draw the button anywhere on the worksheet.
3. Select the macro to assign and click OK.
4. Select the button’s text and type your own button name. You may format the text any way you wish.
5. Click off of the button to deselect.
   * To run the macro, click the button with your mouse.
   * To edit the button, right-click on the button and select your options.

User-Defined Functions

Create a Function Procedure

1. Open Visual Basic Editor by going to Tools→Macros→Visual Basic Editor OR press ALT+F11.
2. Go to Insert→Module to open the Code window.
3. Go to Insert→Procedure… to open the Add Procedure dialog box.
4. Name the procedure and provide the arguments between the parentheses.
5. Define what the name of the function equals (what calculation to perform).

```vba
Public Function Commission(SubTotal)
    Commission = SubTotal * 0.05
End Function
```

Use an Application Object

```vba
Public Function SalesTax(State)
    SalesTax = Application.VLookup(State, Range("Tax_Rates"), 3)
End Function
```

Control Procedure Flow

```vba
If Name = "n" Then
    Name = Application.FunctionName(arguments)
ElseIf Name = "n" Then
    Name = Application.FunctionName(arguments)
End If
    Name = formula
```

```vba
Public Function Discount(Sales, Customer)
    If Customer = "R" Then
        Discount = Application.VLookup(Sales, Range("Discounts"), 2)
    ElseIf Customer = "W" Then
        Discount = Application.VLookup(Sales, Range("Discounts"), 3)
    End If
    Discount = (-1) * Discount * Sales
End Function
```
Write a Subroutine

```vba
Public Function Discount(Sales, Customer)
    If Customer = "R" Then
        Discount = Application.VLookup(Sales, Range("Discounts"), 2)
        Discount = (-1) * Discount * Sales
    ElseIf Customer = "W" Then
        Discount = Application.VLookup(Sales, Range("Discounts"), 3)
        Discount = (-1) * Discount * Sales
    ElseIf Customer = "" Then
        Discount = "Please Enter Customer Code"
    Else
        Discount = "Invalid Customer Code"
    End If
End Function
```

Customize Excel

Share a Workbook

1. With an Excel workbook open, go to Tools → Share Workbook.
2. On the Editing tab, select Allow changes by more than one user at the same time. This also allows workbook merging.
3. On the Advanced tab, select the Automatically every option, and then click OK.

Create a Cell Comment

- Select a cell and go to Insert Comment and type your message. A red dot will be placed in the upper-right corner of the cell.
- When you move your mouse cursor on a cell with a comment, the comment will appear.
- Right-click a commented cell and select Edit Comment to edit the message.
- Go to Edit Clear Comments to remove comments.

Create Custom Cell Formats

When creating a format for a cell, there are four types of numbers or text that you need to specify how you want them to appear.

<table>
<thead>
<tr>
<th>Code</th>
<th>Display</th>
</tr>
</thead>
<tbody>
<tr>
<td>d</td>
<td>Day (d=1, dd=01, ddd=Mon, dddd=Monday)</td>
</tr>
<tr>
<td>m</td>
<td>Month (m=1, mm=01, mmm=Jan, mmmm=January)</td>
</tr>
<tr>
<td>y</td>
<td>Year (yy=02, yyyy=2001)</td>
</tr>
<tr>
<td>_ (underscore)</td>
<td>Insert space in a number format [when you follow an underscore with a closing parenthesis _], positive numbers line up correctly with negative numbers that are enclosed in parentheses</td>
</tr>
<tr>
<td>* (asterisk)</td>
<td>Repeat the next character in the format to fill the column width</td>
</tr>
<tr>
<td>0</td>
<td>Displays a digit, if one exists in the position. A zero displays if no digit exists.</td>
</tr>
<tr>
<td>#</td>
<td>Displays a digit, if one exists in the position.</td>
</tr>
<tr>
<td>$</td>
<td>Displays a dollar sign in the position</td>
</tr>
<tr>
<td>.</td>
<td>Displays a decimal point in the position</td>
</tr>
<tr>
<td>,</td>
<td>Add commas as thousands separators</td>
</tr>
<tr>
<td>@</td>
<td>Indicates that an alpha character is required</td>
</tr>
<tr>
<td>&amp;</td>
<td>Indicates that an alpha character is an option</td>
</tr>
<tr>
<td>“ABC”</td>
<td>Displays anything inside quotation marks as literal characters</td>
</tr>
<tr>
<td>\</td>
<td>Display for following character as literal</td>
</tr>
<tr>
<td>[color]</td>
<td>Displays the result in the color specified. (red, magenta, yellow, blue, cyan, green, black, white)</td>
</tr>
<tr>
<td>;</td>
<td>Separates sections in the syntax of the cell</td>
</tr>
</tbody>
</table>
**Add a Background Image to a Worksheet**

1. To add a background pattern, go to **Format** → **Sheet** → **Background**.
2. Browse to the image you want and click **OK**.
3. To remove the pattern, select **Format** → **Sheet** → **Delete Background**.

**Create a Custom List**

1. Select an existing list and then go to **Tools** → **Options** → **Custom Lists**.
2. Click **Import**. You’ll see the cell references to the range of cells containing your list. → **OK**.

   Edit the list by returning to **Tools** → **Options** → **Custom Lists** and select your list on the left. Edit the list to the right by pressing ENTER after each entry.

**Create a Custom Menu**

1. Go to **Tools** → **Customize**… → **Commands** tab.
2. Scroll to and select **New Menu** under **Categories**:
3. Click and hold **New Menu** under **Commands**: and drag it up to the menu bar in any location you desire.
4. Select a category and drag the command of your choice to the new menu.
   - Rename the menu by right-clicking **New Menu** and edit the **Name:** field. Use the ampersand (&) in front of any character you’d like underlined for shortcuts. (i.e. F&format will be Format)

**Customize a Toolbar**

1. Go to **Tools** → **Customize**… → **Toolbars** tab.
2. Click the **Commands** tab and select a category and drag the command of your choice to the new toolbar.
   1. Edit any button while the **Customize** dialog box is still open by right-clicking any button and select **Edit Button Image**.
   2. Move any button by holding ALT while dragging the button to a new location.
   3. Remove the button by dragging it off the toolbar.
   4. Reset any toolbar to the default by going to **Tools** → **Customize**… → **Toolbars** tab and click **Reset**.

**Customize How You Move**

1. **Tools** → **Options** → **Edit** tab.
2. In the **Move Selection after Enter** drop-down box, choose the direction you want the selection to move to.